1. Dismiss Notice
  2. Dismiss Notice
  3. Hey Facebook people... We've created a group for XS650.com members to connect. Check it out!
    Dismiss Notice

New Profile Posts

  1. lefty4137
    lefty4137
    Looking for a green 1978 tank. Just picked up an all original 78 today....tank is dented and creased. Would like to keep it original!
  2. Cafe Murdock
    Cafe Murdock DogBunny
    Hey I uploaded pics of them air boxes
  3. LiveSlowDieWhenever
    LiveSlowDieWhenever Jim
    Hey Jim, just wanted to personally apologize for falling off the face of the earth. Im back to work on the bike again, and look forward to your insight on whatever comes next on this basket case. Cheers
    1. Jim likes this.
  4. Cafe Murdock
    Cafe Murdock
    Fall from Grace cafe n desperate need of cpr help plz
  5. Sorberjon11
    Sorberjon11
    Wondering what electrical components are absolutely necessary for a clean up of the electrical system.Blinkers needed.
  6. Sorberjon11
    Sorberjon11
    New Member. 1977 XS650
  7. G_YamTech_314
    G_YamTech_314
    Holy crap... winter is over already? Why does my build look the same?
  8. Henrythecat
    Henrythecat db1337
    Hello! Quick question: What size Heidenau K60 tires are on your bike in the pics. I wanna get a pair but im not sure what size to get. Thanks in advance!
  9. Carter5450
    Carter5450
    Got her started up today it was a huge relief to hear the big twin come to life
  10. Grimmith
    Grimmith
    Working on making my own custom tail light. Molding with epoxy and then hand carving.
  11. LeisureMaster
    LeisureMaster
    That woohoo moment
  12. hallsteve35
    hallsteve35
    Going to have to sell my bike
  13. ramblin5
    ramblin5
    Retired and Riding
  14. Jadga
    Jadga
    First 650 Bobber build
  15. raimitm
    raimitm rstar45
    Hey, just read your thread where you used the earth magnet solution. I've been doing the same, applying JB weld but it doesn't stay on more than 20 min on the highway. What did you do to keep it on? Let me know, thanks!
    1. Wulfbyte likes this.
    2. View previous comments...
    3. raimitm
      raimitm
      Wow cool to hear the magnets have been that reliable.
      My magnets fell off a few times, now I finally got it glued on good but as I was on the highway I got the same backfire, stuttering, then stall. Weird thing is this time the magnet stayed on. But the bike is acting like the magnet fell off. Unplug the reg/rec and everything is fine, besides charging. Not sure where to go from here
      Mar 7, 2019
      Wulfbyte likes this.
    4. Wulfbyte
      Wulfbyte
      Check your pick ups! You might need to raise it,I put to tiny washers under the plate your pick ups are on to raise it a bit of the generator housing, your magnet might be hitting the pick ups which will knock it off your rotor! Which sounds like that might be happening! If so check your pick ups and make sure the magnet hasn’t damaged them any!
      Mar 7, 2019
      raimitm likes this.
    5. Wulfbyte
      Wulfbyte
      The two tiny washers will raise the pickups enough for clearance and still have good connections!
      Mar 7, 2019
  16. Tim Meaders
    Tim Meaders
    I will not be another old man riding a Harley! But, I will be another old man riding a Yamaha XS650.
    1. Wulfbyte likes this.
  17. Steven Simpson
    Steven Simpson
    1981 xs650 chopper current build
  18. JAX71224
    JAX71224
    Gathering parts for cruisinimage 706 bore up and shell cam. Gonna have a little more oomph next spring, I hope......
  19. ninedub
  20. moto101
    moto101
    Back at the hardtail build and trying to keep the others happy.