1. Dismiss Notice
  2. Hey Facebook people... We've created a group for XS650.com members to connect. Check it out!
    Dismiss Notice

1980 ignition problems

Discussion in 'The Garage' started by prue1, Feb 26, 2018.

  1. prue1

    prue1 XS650 Enthusiast

    My friend recently acquired a 1980 XS 650 special. It is my understanding that this was the first year for pointless/electronic ignition. It has no spark, any advice on where I should look first? Thanks.
     
  2. Jim

    Jim Beyond the edge, is the unknown. Here be Dragons XS650.com Supporter Top Contributor

    Well.... checkin' the fuse would be my first step. After that, you're gonna need a meter. I'd recommend going through the TECH section first. After you get a basic understanding on how the TCI system works, it will much easier to help you. Good luck.
     
  3. 5twins

    5twins XS650 Guru Top Contributor

    18,851
    9,661
    688
    Yes, check the fuse 1st, then all the wiring pertaining to the ignition. In particular, check/test the wires running to the pick-up on the alternator. They have been known to break inside their sheath where it gets clamped. Check the spark plug caps as well. They can go bad, or maybe they're loose on the plug wire or have a bad connection to it.
     
  4. prue1

    prue1 XS650 Enthusiast

    Thanks guys. I'll be headed his way latter this week to check these suggestions out.
     
  5. xschris

    xschris from earth

    468
    14
    18
    usa
    Make sure you have a fully charged battery.
     

Share This Page