1. Dismiss Notice
  2. Hey Facebook people... We've created a group for XS650.com members to connect. Check it out!
    Dismiss Notice

An Adventure in Firsts: '83 XS650 Heritage Special Build/Rebuild

Discussion in 'The Garage' started by MarieKaramazov, Oct 20, 2020.

  1. 5twins

    5twins XS650 Guru Top Contributor

    20,870
    13,553
    813
    Well, usually one just disassembles the brake components and cleans them out (the master cylinder and the caliper). But like I said, I don't think you're equipped to do that. The master cylinder requires some long reach snap ring pliers to get it apart and the caliper usually requires compressed air to blow the piston out. I've renovated quite a few of these and usually just a disassembly and thorough cleaning is all that was needed, no new replacement or rebuild parts.

    Like I said, yours looks pretty bad. There's a good chance the piston area below the reservoir you've looked into is all packed with gunk. It probably isn't pumping fluid like it should and that's why the brake is so weak. It's barely being applied. As also mentioned, a basic fluid flush and change usually won't clean all the crap out. So, you have a decision to make - attempt to renovate what you have or buy a new MC. But that won't address the possible caliper issues. Eventually you're going to have to take that apart and clean it out. Eventually it will start making the brake pads stick and drag. Don't be like a local guy I know. He let his get so bad you could barely push the bike around, lol. A complete disassembly and cleaning of both his MC and caliper had the brake working like new again (no new parts needed).

    One more thing I should mention. You'll want to replace your brake line with a stainless one. They're dirt cheap on eBay now, less than $10. A 90cm long line is perfect for lower bars.
     
    Raymond and MarieKaramazov like this.
  2. Machine

    Machine Race the wind Top Contributor

    Very good points as well 5twins, I agree a complete brake system thorough cleaning is now on the to do list.
    About those Chinese braided stainless brake lines. The ones I got had bigger (wider) banjo fittings which require sourcing appropriate brake line banjo bolts as well. Fortunately I found some Honda bolts to be good. And, it sure would be nice to have the option of ordering lines with the banjo fittings rotated 90° to each other instead of inline as the braided lines really do not like being twisted.
     
    Raymond and MarieKaramazov like this.
  3. Actually, the house I'm at has pneumatic tools (compressed air, etc); he rebuilt that corvette and a 50s Cadillac limo here so I think he'll have those pliers; and I have transportation to stores around here with a car (and yeah, I wish it was the corvette or the Cadillac). That's why I came out here--space and tools. So as far as tools and equipment go, this is a tooled as I get. So if cleaning those and flushing lines are a job I can do in a day with my skill level, seems like I should just do that today. As well as finish clutch cable. I want to get a new MC anyway though... I'll look into what the cleaning out rust (from MC and caliper) looks like--what solvents I'll need to clean etc--and see if I can get to it today. Otherwise it'll be new fluid, bleed, ride home, order new MC and cable, then come back out here when I have time again to put on new mc and clean caliper and replace brake line.

    It does seem to be the front brake that is squeaking by the way @Machine. There is what looks like a fork seal leak but on left side.

    Stay tuned.
     

    Attached Files:

    Raymond, Machine and jetmechmarty like this.
  4. 5twins

    5twins XS650 Guru Top Contributor

    20,870
    13,553
    813
    My goodness, yes, lol. Looks like that left fork seal has been leaking for some time seeing that the oil that ran down the fork lower has been all coated with dirt now. Looks like it's let up too, or that dirt would be getting washed off by freshly leaked oil. Maybe that leg is empty now, lol. The right side is leaking too though. You can see all the oil on the fork tube. Wipe that off and keep an eye on it, see how much and how quickly more accumulates.
     
    Raymond, MarieKaramazov and Machine like this.
  5. Machine

    Machine Race the wind Top Contributor

    Take that as a positive being that the pads are still dry. Squeeking poor braking could also be a result of the caliper mount bolt through the "sliding bushing" under the accordian style black rubber boot there in your pic. That bushing needs to be clean and greased so the caliper can float and center itself as the brake pads wear. If it's too dry and stuck, one pad is doing all the work. That's a No Go.. caliper looks pretty good.
    20210303_143815.jpg
    And your fork seals are leaking and will get worse if you do not immediately pop up the dust covers and clean out the gook. Wipe em, change the fork oil soon.
    20210303_143941.jpg
     
    MarieKaramazov likes this.
  6. Jim

    Jim Beyond the edge is the unknown. Here be Dragons XS650.com Supporter Top Contributor

    Make sure you use a silicone based grease on that bushing. Petroleum based grease will swell the rubber and make things worse.

    PXL_20210303_231845186.jpg
     
    Team Junk, Raymond and MarieKaramazov like this.
  7. Raymond

    Raymond XS650 rider & fettler XS650.com Supporter Top Contributor

    Marie, you're definitely getting there. Your recent posts, such as #483, show growing understanding and confidence.

    Rust that's stuck in the master cylinder won't add to your problems. Well, not short term while it stays stuck. But cleaning the system before changing the fluid is a good idea if you have the time and resources. Use DOT4 brake fluid from a new and sealed container.

    Quite satisfying when you get into the routine of squeeze the brake lever with one hand, loosen then tighten the bleed nipple with the other, release and re-apply the brake, etc. Keep going till fluid is clear and no bubbles. You'll know you've done a good job when the pulled lever feels rock solid.
     
    MarieKaramazov and Jim like this.
  8. fredintoon

    fredintoon Fred Hill, S'toon. Top Contributor

    Hi Marie,
    DOT3 has a slightly lower maximum temperature rating than DOT4 and those fluids will mix together OK.
    What's mostly available is DOT 3/4 anyway.
    Do NOT use DOT5, it's what Harleys use, it's a different fluid and it plain ol' don't mix with DOT3/4.
     
    Raymond and MarieKaramazov like this.
  9. Hi all!
    I used DOT 3 as that's what was listed on the lid of the MC. I hope that's okay! The bleeding was a success I think. It was tough to do as a single person job because the tube wanted to come above the liquid (I referenced this post), so my step dad managed the lever while I did the opening and closing of the nipple. We ended up doing a back and forth of open and closing the nipple a few times--and hopefully he was listening when I said to keep the lever closed when I opened the nipple haha cuz I couldn't look up and manage the hose. He said he'd done it before so hopefully I'm good! Saw some sediment come out of the tubing. A few bubbles a few of the times but in the last few dances back and forth there were no bubbles or sediment. And fluid is FAR more clear now and the brake feels tight.
    Changed and rerouted the clutch cable and adjusted the mechanism. Fingers crossed what I did makes for a good pull still.
    Padded the battery area. Ugly but it works.
    Swapped the bars.
    Traced the seating area for a possible future seat pan.

    Topping it off with oil this afternoon and then going to test the clutch and brakes, quick assessment of leaks (and see if the oil is moving around in the sight as it normally should), and then heading back if all is well.

    Didn't get to that bushing and the silicone as I didn't have any on hand and was short on time. It'll go on the list!

    Is there a special method to popping these that I need to look up? My brain wants to just get in there with a Philips a rag and a rubber mallet...
    For now I wiped what was on the forks and boots and I'll be able to see what it does on the ride back.
     

    Attached Files:

    Team Junk, Raymond and jetmechmarty like this.
  10. 5twins

    5twins XS650 Guru Top Contributor

    20,870
    13,553
    813
    You may have bent and kinked your new clutch cable a bit too much up at the lever by directing it down and under the instruments. Just gently arch it over the top of them like so .....

    [​IMG]

    The angle of the pic is deceiving. The cable doesn't block your view of the instruments at all. It does sort of block key insertion and removal but all you do is push the cable up of down slightly to get at the key, no big deal.

    Your last pic very well illustrates how the main wiring harnesses on each side of the steering neck that run up into the headlight tend to sag down over time. Eventually that may end up pulling the harness sheath out of the headlight bucket. You need to install what I call my harness "sling". This is nothing more that a couple cable ties inserted through the existing holes in the gusset plates around the steering neck, then looped around each harness and snugged up. Snug them up enough to lift the harness section up under the tank puck cups on each side .....

    [​IMG]

    [​IMG]

    The above pics are from my 1st installation. The sharp edges of the holes ended up cutting the cable ties after a couple seasons so I now stick grommets in the holes first .....

    [​IMG]
     
  11. Machine

    Machine Race the wind Top Contributor

    20210304_115233.jpg
    Easiest way I've found to "pop up" the dust boot is to gently poke a dull 90° poker in there under the bottom lip and then go either direction while pushing the boot up too.
    Once in there for a temporary improvement you can wrap a bit of absorbent such as paper towel and push the boot back down over it.
    Will temporarily absorb the accumulated leaking and help with cleaning.
    Bel Ray use to sell fork oil with "seal swell" in the mix. That I have used on dirt bikes to help fight fork seal leaking
    You are doing well !
    -R
     
    MarieKaramazov and jetmechmarty like this.
  12. fredintoon

    fredintoon Fred Hill, S'toon. Top Contributor

    Hi Marie,
    if you are using a stock (12 N 14) battery it's best mounted in it's correct battery boot
    instead of padding it to fit. XS650 Direct part #02-6529.
    Suggest you buy their battery holder rubbers & tie-down strap too.
     
  13. 5twins

    5twins XS650 Guru Top Contributor

    20,870
    13,553
    813
    I can't recommend the aftermarket battery strap. The one I got from MikesXS (most likely the same item) only lasted a couple years before breaking. Originals are still available from Yamaha and while they cost a few dollars more, that quality part will likely last a lifetime. The original on my '83 seems to still be in fine shape .....

    https://www.partshark.com/oemparts/a/yam/500423e7f8700209bc787bf8/electrical-1
     
  14. Jan_P

    Jan_P XS650 Junkie

    509
    746
    93
    Sweden
    Raymond likes this.
  15. 5twins

    5twins XS650 Guru Top Contributor

    20,870
    13,553
    813
    Yes, they actually make and sell a tool .....

    https://sealmate.net/

    It's true that many times just dirt in the seal is causing the leak and the seal is still OK. I don't replace slightly leaking fork seals, just clean them and that usually fixes the leak.
     
    Raymond and Jan_P like this.
  16. Jan_P

    Jan_P XS650 Junkie

    509
    746
    93
    Sweden
    Thank You Gentlemen I have a set of fork legs with one of them leaking
    This changes what I will do next . I was slowly planning to go in the hard way
    Lot of work + Ordering seals .. and so on
    I Will get the Camera Film and make a small hook at the end I put in and if that catches dirt I will install them.
     
  17. 5twins

    5twins XS650 Guru Top Contributor

    20,870
    13,553
    813
    I actually bought the tool and it's just made of thin plastic. You might be able to make one from an old plastic milk jug.
     
    Jan_P likes this.
  18. So I made it back. Two main issues on the ride: caliper nipple and shifting stiffness again (bad clutch mechanism adjustment).

    (1) Before I left, I noticed a bit of a sheen and some wetness on the caliper around the nipple. Rotor seemed clean. I figured it was just some remaining brake fluid from the bleed. I wiped it down and tested the bike around the block a few times, doing emergency stops, to see if it was leaking. I didn't see any more come out. I kept an eye on it while I rode as I know if it leaks out and gets on the rotor I'm in trouble. It was hard to tell at a few of the stops, but eventually it was clear that it is slowly leaking the tiniest bit.
    IMG_2940.jpeg
    I had tightened the nipple after the bleed, and I tested to see if it was loose enough to just crack open by hand and it's not, it's tight. Someone had suggested that maybe the nipple is cross threaded (I never totally took it out, just cracked about a half turn)
    IMG_2931.jpeg I'll get a closer pic, but if you zoom in on this one you can kind of see that the nipple is at a slight angle.(or see post 485..though these pics are pre bleed, but if I didn't unscrew it all the way I don't see how I'd have cross threaded it.) I'd thought it looked like that just because of where the screw was at in the hole and cuz it is at a bit of an angle.
    I feel like if it was a cross threading that was causing the leak, then the nipple would've been slow leaking the whole time I had the bike, which I have not seen. And again, I didn't unscrew the nipple all the way and remove it, so crossthreading being a new thing doesn't seem to add up. So I'm not sold on that explanation.
    My only thought so far was that perhaps I'd filled the MC reservoir so much (filled it to the very top to the point where it overflowed when I put on gasket and screwed it down) that when I do use the brake, it's forcing some of the fluid out of the nipple because there's too much pressure? But that doesn't sound right either because the amount it forces down to caliper should be the same either way..
    In the meantime, I'm wiping it and keeping and eye and riding as little as possible.

    (2) The pull on clutch lever was fine, about the same, so not thinking routing is a problem yet thou it wouldn't hurt to make it easier on my self and sacrifice having to see the cable up top more; lever not loosening much even after riding though. After some time riding back though, again the foot shifter will not shift up to neutral from first at stops, and still requires that special foot tap to go down from second. I've resolved this in the past with adjusting the clutch mechanism again. I did notice I was getting a slightly different idle reading whether in first with clutch lever in versus neutral, so I may have just done an off adjustment...I did even do it twice because it was off the first time. I'll do it again, but I guess my question is whether the issue is that I'm not turning the adjuster screw in enough, right, so the clutch is not releasing even when I have lever in? Weird it's only first to Neutral and at stops.. I feel like I get it real tight, with fanning the clutch through the freeplay and then backing it off about a 1/4 turn, so I'm not sure what I'm doing wrong. Perhaps just tighter I suppose. And of course before I do the mechanism, at the perch I turn the adjuster all the way in and then back out a full turn. I don't adjust at the perch after since it usually feels good at that point after clutch mechanism adjustment.

    Forgot to check oil leak when I got back. I can say that when I topped it off before I left and then ran it, the oil was running as it normally does in the sight on the right side. It took about a half a bottle to get it to the right level. I still don't see how the oil was so low when I only did the only change a month or so ago; in other words, I wonder if there's a bigger leak I'm not seeing. To be continued...

    Idle started running lil high (1.5-1.6k+) again after about 1 hour. Took almost a full 1/4 turn on idle adjustment screw to get it down, but then it wanted to drop too low. I may just need to fine tune my approach there.

    *
    Hoping to order new and different master cylinder, stainless brake hose, silicone brake part grease for bushing ASAP.. Will need to look into what parts and specs I need to follow to make sure I get ones that work .

    I'll try to pop the boots and do that clean job and trace the leak this week as time allows.Thanks for that link @MacMcMacmac . Hoping to get back to the work spot next week to do bigger job like caliper clean and MC swap, but would like to solve nipple leak before of course.

    I do have the holder and strap, I just had it pulled out of the way in that photo. Not using stock battery. I'll likely add some more padding down the line.
     
    Last edited: Mar 6, 2021
    Raymond and Jim like this.
  19. 5twins

    5twins XS650 Guru Top Contributor

    20,870
    13,553
    813
    With all the gunk in the system, it's possible the bleed nipple won't seal perfectly because of it. There may be crap on it's seat.
     
    Team Junk, MarieKaramazov and Raymond like this.

Share This Page