1. Dismiss Notice
  2. Hey Facebook people... We've created a group for XS650.com members to connect. Check it out!
    Dismiss Notice

my jeep is driving me crazy!!!

Discussion in 'The Lounge' started by bergoff, Aug 26, 2013.

  1. bergoff

    bergoff XS650 Addict

    I have a 99 Grand Cherokee 4.0L that has been running really weird lately. When you first start it's fine after 30sec it will run rough and backfire through the throttle body. And then all of the sudden its fine. And it will be fine until you shut it off. It will usually last between 15-60sec. I've changed the fuel filter and also the tps and cleaned the iac and tb. And it still does it. There is no codes and no check engine light. Before it starts to run rough I can hear it sucking air like crazy through the throttle body. I'm not sure if I just have a vacuum leak or a sensor freaking out. And my air vents will switch on their own from time to time. This is why I'm thinking it's a vacuum leak. I tried tonight after work to find a leak with propane and no luck.

    Any thoughts? I'm also thinking buying a bluetooth OBD II scanner so that might help me figure it out.
     
  2. TwoManyXS1Bs

    TwoManyXS1Bs BBQ Hunter Top Contributor

    I've been working on my `99 Tahoe, joined 2 Tahoe forums to learn more. These OBD-2 machines go thru a sequence during the warmup period, and I think that your 30 delay is close to when the evap purge cycle occurs, which uses the vacuum line(s). Whatcha think?
     
  3. TwoManyXS1Bs

    TwoManyXS1Bs BBQ Hunter Top Contributor

    I got the ELM327 bluetooth gadget, link it to Android app "Torque", very handy. But I later got the ScanGuage-II, direct connect, mounted it to the dash, highly recommend...
     
  4. gggGary

    gggGary I'm listening, change my mind XS650.com Supporter Top Contributor

    Scan gauge is nice I am on my second one turns out they won't survive being shut in the drivers door. :banghead:
     
  5. goodgollyjosh

    goodgollyjosh XS650 Addict

    As Twomany mentions, joining a forum is probably gonna be your fastest method to solving this problem. I imagine they have likely seen the issue before and if not then I would recommend iatn.net. It is a technician support forum, I have been a member for 15 years and it has saved me a lot of headaches. I like the fact that you must help others on the site before you can post your own question. It makes it fair for everyone. Good luck to you.
     
    Last edited: Aug 26, 2013
  6. 1974jh5

    1974jh5 Curmudgeon.

    Worked at a Jeep dealer for 5 years. Take the battery out and look down in that corner. You'll see vacuum lines which go to the cruise control servo. They are famous for battery acid eating away the vacuum harness which then causes weird driveability problems, the cruise does not work and the HVAC controls (manual AC only) will start blowing through the defrost only.

    Like the bumper stickers say: It's a Jeep thing. :wink2:
     
  7. Inside the front bumper there is a vacuum reservoir disconnect and block off for a test they will leak will little noise......... definitely sound like vacuum leak issue.......
     
  8. Need more info on the tahoe I've been a GM tech for 30+ years I"LL help if I can.:bike:
     
  9. bergoff

    bergoff XS650 Addict

    Thanks guys I knew I could get some help here. I posted on 2 jeep forums and nothing. I pry won't get to work on it until Wednesday its to damn hot. And my bluetooth scanner will be here by the end of the week.

    I've owned my Jeep for 12 years and its been the best vehicle that I've ever owned.
     
  10. TwoManyXS1Bs

    TwoManyXS1Bs BBQ Hunter Top Contributor

    Fantastic! I'll definitely be taking you up on that. When you posted, I was under the hood looking for and refreshing all the battery cable terminals/ends and engine/frame/chassis grounds. I have the 8" thick 4-volume 1999 service manual(s), my eyes hurt now. The truck runs fine, just doing a bunch of preventative medicine.

    Biggest issue right now is the factory delco radio/cassette w/ remote CD, clock always resets to 1:00. Decided it's the head unit, have another coming (with aux jack mod).

    Thanx, DIRTY DOG...
     
  11. bergoff

    bergoff XS650 Addict

    Well no vacuum leaks. So now I'm thinking it might be the crank position sensor.
     
  12. 1974jh5

    1974jh5 Curmudgeon.

    I doubt that, a CPS will cause an intermittent 'spins over but won't start' and also a stalling problem with difficult restart but not what you describe. I still think you have a vacuum leak somewhere, the hiss is the idle air control as the PCM tries to make up its mind.

    You might check the throttle position sensor. This test works best with a 'needle' or analog type voltmeter: connect the leads across the TPS wires then open the throttle slowly, watch the needle. If it moves in a steady fashion you are good. If the needle jerks back and forth or whacks back to 0 then back up then the TPS is bad and no this won't set a fault code. This can be done with a digital but it's a PITA trying to read the numbers.

    Whatever you do, don't mess with the throttle plate stop screw! Those are set on a flow bench during assembly and if they are tampered with all kinds of weirdness will happen.
     
  13. DozerDan

    DozerDan XS650 Enthusiast

    79
    0
    6
    NJ
    A TPS or CPS that is on the fritz could cause that. I have seen it in a few of mine and in my sisters jeep. I keep some spares in the tool box to use as test units.
     
  14. jeeper96

    jeeper96 XS650 Member

    The 4.0 was infamous for the injector o-rings causing probs like that. At least the 3 ive owned. Just a thought and two cents
     
  15. bergoff

    bergoff XS650 Addict

    I've been to busy to work on it. 60hr work weeks are killing me. Plus some tard stole my debit card info and drained my bank account so waiting to get that all taken care off. Then I will focus on the Jeep. Thanks for the info guys. My local mechanic said he will give me some pointers if I get stuck also.
     
  16. TwoManyXS1Bs

    TwoManyXS1Bs BBQ Hunter Top Contributor

    Oh crap! That just plain sucks BIG time! You hear about this on the news, it's always somebody else, but this is gettin' too close to home!

    I've made arrangements with my bank to put special limits on my debit card. And they have a monitoring feature that rejects transactions that don't follow your spending style/location/amount.

    Situational awareness is the key...
     
  17. Just got a Jeep Liberty 2004 with a 3.7 motor in the shop that's a friends girlfriend and recovered thief. They stole the fans air box and one cat. WEIRD. It started so now the hunt for parts. Never worked on a JEEP its sitting next to my NOVA project. NEW VS OLD HAHA
     
  18. 1974jh5

    1974jh5 Curmudgeon.

    Just remembered something about 4.0 Grands: at the back of the engine on the right (passenger) side the wiring harness can rub against a cylinder head stud, this gnaws a hole through the sleeve and eventually the insulation of the wires. For some reason, the most common wire to rub through is the TPS wire, IIRC it's yellow with a black tracer. Worth a look.
     
  19. bergoff

    bergoff XS650 Addict

    Well it was the crank position sensor. What a pita that was but it sure was cheaper than taking it to the garage.
     
  20. bergoff

    bergoff XS650 Addict

    Ok so 3 days after I thought I had it fixed it started to do it again. Turns out its the upstream o2 sensor and I can't get it out. If tried wd40 soak for days and then heat. Still won't move. I might cut it so I can get a regular socket on it. I don't have one of those fancy sockets for o2 sensors.

    This thing has been a pita lately. The heater core went out. So I had to remove the entire dash. It wasn't to bad only took me 5 hrs and a case of PBR so I could use my friends garage.
     

Share This Page