1. Dismiss Notice
  2. Dismiss Notice
  3. Hey Facebook people... We've created a group for XS650.com members to connect. Check it out!
    Dismiss Notice

Quick diagnosis confirmation - carb/fuel issue?

Discussion in 'The Garage' started by puftas, Jun 8, 2019.

  1. puftas

    puftas XS650 Member

    Been getting my 77d on the road again, after 2 years of sitting and me replacing most of the electric system. And I should probably have given my tank at least a good rinse before using. She's riding, I've been out on her the last 2 weeks, but she's been gradually running worse.

    Symptoms:
    • Runs fine intermittently, and when I first had her out.
    • Now worsening loss of engine power when I throttle on.
    • seems to be in only first 1/4 of throttle, so I'm assuming pilot circuit is the issue
    • Sometimes I go and start her, and for a few minutes she runs fine.
    • Then the power loss starts in again.
    • Seems to be slightly worse when I'm in gear, clutch engaged vs neutral. But my gears normally drag a little.
    • makes what I would call a PUTT-PUTT PUTTERING sound as you roll on, and doesn't grab like she should
    • sort of a low burbling that shouldn't be there. Normally she sounds more like a sewing machine
    This is the pilot circuit yes?
    • gas vent should be good.
    • need to check my inline filters, but I think they're flowing okay.
    • charging/battery/electric all seems to be great (thank Hugh for PMAs)
    Just wanted to check with others that I've read the symptoms correctly, before I do another carb-clean. Starting to get a little more confident in my diagnosing skills, and damn that saves a lot of needless wrenching.
    Tank is not bad at all. More varnish than rust. But prolly enough to plug the pilot. Now just gotta figure a way to clean my it out in an NYC apartment or on the street... :umm:
     

    Attached Files:

    gggGary likes this.
  2. TwoManyXS1Bs

    TwoManyXS1Bs BBQ Hunter Top Contributor

    GLJ and gggGary like this.
  3. xjwmx

    xjwmx XS650 Guru Top Contributor

    7,012
    2,391
    313
    U.S.A.
    The "putt-putt-puttering" when you roll on really sounds like one cylinder dropping out, possible float level. Floats started leakin? Needle valve leakin?
     
  4. puftas

    puftas XS650 Member

    UPDATE: popped the carbs off, found some metal in the mix tube. like shavings from a stripped thread. no idea where that's from. I think she was losing a cylinder when I rolled on, but she's running now, and not bogging anymore. All good, and on to the next things to fix.
     
    TwoManyXS1Bs and gggGary like this.

Share This Page