Resolved: 2006 Stratoliner starting issue.


Traveling Stroyteller
Top Contributor
Reaction score
Dumfries Virginia
First, a quick recap of this 2006 Stratoliner that my cousin gave me in June. He bought the bike cheap, it has 117K miles on it. It is too big for him and his age makes him less inclined to ride a big bike.

The PO told him the starter button was going bad but it still worked if you changed your thumb position on the button. Sounds logical, right?

I went to Texas from Virginia and brought it home in my pickup. The first thing was to have new tires put on it as the front tire was three years older than the bike! My local dealer put Bridgestone Exedra Max tires on it, my favorite for my Triumph Rocket III Touring. And, they put a state inspection sticker on it even though I have not yet got to my appointment to title it in my name. Due to this pandemic thing shutting down DMVs in my area, my appointment is not for another four weeks.

I named this bike Yamato. Seemed fitting because it is a Yamaha and a motorcycle so a mashup of the two. And, the Yamato was one seriously badassed Battleship. And since a Stratoliner is the biggest in the lineup, it works for me.

I rode Yamato to work several times and put 200 miles on it before the starter button would no longer turn the starter. I opened the right hand bar assembly where the starter button is and cleaned the inside with CRC electrical cleaner.
Dirty RH assembly note cable.jpg

And after cleaning:
clean RH assmebly.jpg

I could not get to the actual switch to unhook it without disconnecting the throttle cable. I was not prepared for that so I just cleaned everywhere inside. That didn't work, just get a click from under the seat.

Alibi here: I do not understand exactly how to use a voltmeter correctly. I do know that I must gain this skill before I start rebuilding my '81 XS650 "Rusty"; another fitting name. This skill would have helped my troubleshooting had I had such for Yamato.

I did not know much of Yamato's history other than over the last year it has only been ridden 150 miles or so. Maybe the battery is just too old. I could not see a date anywhere on the top of the battery. So I went on line and ordered one (I know, that is premature and I shouldn't spend money if it is not needed). It should have arrived two days later. The next day I received an email saying it was back ordered and wouldn't be here for 2 weeks. Well that won't work.

I called around to the auto parts stores and found several for the bike so I pulled the battery to take in for the trade and to have it load tested. Once there, we found the date sticker: 11/19. It is not even a year old, huh. They load tested it and found that it is in great shape. So I took it home and cancelled the online order.

So what next? The starter relay is easy to reach. I pulled it, tapped it on the ground and reinstalled, Well that didn't work. But I did affirm the click is coming from the relay.
Old starter relay.jpg

I was successful at jumping the relay and starting the bike. That tells me it is indeed the relay that is bad.

This is how I jumped the two leads in the simulation below, I used an old screwdriver when it was on the bike. Lots of sparks, looks cool in the dark.
Jumping realy leads.jpg

Two days later, and aftermarket relay shows up. I go out with the threat of rain looming overhead that evening. I swapped the relay and the bike started but died right away. I tried several times but could not keep it going. I took the relay off and came inside to consult the Star Bike forum for help. Between that, YouTube and Facebook, I began to realize after market starter relays for the bike are often less than adequate. The OEM parts is on back order too dang it! One guy tells me that the fuel pump gets its power through this relay and if the new unit is bad, that would explain why the bike dies right after starting. No matter for now, it is full on dark outside and pouring rain, I have to wait for the next dry period to continue.

Yesterday, I was thinking that taking the top off of the new relay and putting it on the bottom of the old relay would be my way forward. But first, I was going to use the available daylight after work to try the new relay again and make sure I had it attached correctly. This time, I did not get a start, no click, nothing except lights. WTH?

I took it off and it fell apart in my hands. I lost the copper jumper off the battery side lead somewhere in the bowels of the bike. Luckily I found it after a frustrating search. I reassembled the relay, reinstalled it and Yamato sprang to life and stayed running. Evidently the top was partially loose when I tried it the night before but I did not realize this.

I reiterate that those who have a voltmeter and know how to use it would have discovered where the issue was before I did. I do have a good take away in troubleshooting here which well help me when I start Rusty's restoration. Never stop learning!

Or was this magic?


Grumpy old man
Top Contributor
Reaction score
Carbondale, IL
Well done sir! The only thing the meter might have told you is that the button was OK--if in fact it was OK before you shot it with contact cleaner (maybe it wasn't, more than one defect can contribute to the same trouble). Apart from that, jumping the relay with a screwdriver told you every bit as much as a meter would. Keep having fun! (Multimeters ain't sorcery, just be sure to pick a good 'un that won't lie to you over a cheap one that might.)


XS650 Guru
Top Contributor
Reaction score
CDA ,Idaho
You do know that we sunk the Yamota even though it was there biggest ship. 2500 went down with that one.