1. Dismiss Notice
  2. Dismiss Notice
  3. Hey Facebook people... We've created a group for XS650.com members to connect. Check it out!
    Dismiss Notice

Jimi's Got a Glitch (brake/tail fail indicator light)

Discussion in 'The Garage' started by YamadudeXS650C, Aug 19, 2019.

  1. Jim

    Jim People will come Ray, people will definately come. Top Contributor XS650.com Supporter

    A little cleaner... :rolleyes:

    IMG_20190819_150214.jpg
     
    MaxPete and YamadudeXS650C like this.
  2. YamadudeXS650C

    YamadudeXS650C Central New York XS650 Top Contributor XS650.com Supporter

  3. MaxPete

    MaxPete Life with Lucille...I suggest, she decides. Top Contributor XS650.com Supporter

    Gosh - it looks like something that Mailman has been going over....;)
     
    Jim and YamadudeXS650C like this.
  4. 5twins

    5twins XS650 Guru Top Contributor

    17,776
    7,584
    688
    I took the bulb out of mine. It came on full time when I switched to a L.E.D. tail light bulb. It uses so little current that I guess it fooled the checker into thinking it was burned out, lol. Eventually, I removed the checker. On my '78, it was a simple matter of just unplugging and removing it. But, it was the simple 3 wire checker. Yours is the more complex unit. Mine monitored the brake light only. Yours monitors brake and tail light, and the power for the tail light passes through it. If you remove yours, you need to jumper that tail light power wire together to make the tail light work again.
     
    YamadudeXS650C and MaxPete like this.
  5. YamadudeXS650C

    YamadudeXS650C Central New York XS650 Top Contributor XS650.com Supporter

    I recall reading about this in the previous threads....
     
  6. YamadudeXS650C

    YamadudeXS650C Central New York XS650 Top Contributor XS650.com Supporter

    Altho Robin would have polished it...;)
     
    Jim and MaxPete like this.
  7. MaxPete

    MaxPete Life with Lucille...I suggest, she decides. Top Contributor XS650.com Supporter

    Yup - Bob is a bit of piker when it comes cleaning things...:rolleyes:
     
    YamadudeXS650C and Jim like this.
  8. YamadudeXS650C

    YamadudeXS650C Central New York XS650 Top Contributor XS650.com Supporter

    Update:

    Received the light checker from Jim; very excited to try it.
    Plugged it in, turned the switch, and Voila !! The red light went out ! Yeah !! :D:bike:
    Started the the bike, all is good.
    Turned it off, then turned it back on. The red light is back. Ran the bike........well, you get it, I'm sure.
    The glitch somewhere in my bike killed Jim's light checker, probably the same way it killed mine.
    Darn :(
    I did, in fact, inspect the complete harness and connectors for shorts/opens.
    Well, the lights are still working with my light checker plugged back in.

    Thank you, Jim, for your generosity !
     
    MaxPete, Jim and GLJ like this.
  9. Jim

    Jim People will come Ray, people will definately come. Top Contributor XS650.com Supporter

    Well, it was worth a try. Guess it's plan B after all...
     
    MaxPete and YamadudeXS650C like this.

Share This Page