‘77 front turn signal help

cosmic

XS650 Member
Messages
18
Reaction score
8
Points
3
Location
Georgia
Got my 77 to fire off on starter fluid, just need to wait for new petcocks to come in. Planning on doing turn signals until then.

I’ve looked at some wiring diagrams online and looked at the bike and i can see where the rear turn signals plug in, but I can’t find where the front ones plug in. I took the headlight off and can see all the wires in there and can see where the chocolate and green colored wires from turn signal switch go into the headlight bowl and then go back out and to the rear signals, but I can’t find where the front signals would plug in. I assume the PO just unplugged them but I can’t find a plug for them but I might just not be looking good.

I have another question, when the wires run to the flasher relay, I would assume they run back up to the front? If I knew for sure if the ran back up to the front i could try to follow the wires and see if i can find the ends somewhere
 
You front turn signal connect to the corresponding wires in the headlight. If you can’t find the matching wire they may have been cut or pulled back under the tank. Each black wire are grounded, chocolate and green should connect accordingly. The relay has 3 wires - black to ground, brown/white to turn signal switch yellow/green to the light checker unit. This is all based on you have the original harness. Look in the tech section under electric, lots of good info, also recommend you get a workshop manual - they all fancy the wire harness for each model too. Good luck
 

Attachments

  • IMG_3729.png
    IMG_3729.png
    343.2 KB · Views: 23
In the headlight bucket you should have 2, 3 pin connectors, (female bullet). One Chocolate and one Dark Green, from your loom, to your front indicators. From the indicater switch should b 2 male bullet connectors to plug into the 3 pin female from the rear indicators.

Power from the flasher relay to the indicator switch,(on bar), runs power to indicators when switched on. This is a seperate loom circuit and doesn't go into the headlight except on the brown power wire that powers from the ignition to multiple circuits
 
Last edited:
Should mention, The power wires coming out of the front indicator will b black with a male bullet connector to plug into their respective coloured circuit. Check the rear indicators to see what side the Ch or D/G wires go to
 
Should mention, The power wires coming out of the front indicator will b black with a male bullet connector to plug into their respective coloured circuit. Check the rear indicators to see what side the Ch or D/G wires go to
Okay I appreciate it. I’ve found some ground wires that are open so I assumed that’s for the turn signal, just couldn’t find an open end on the chocolate or green wires for them to plug into
 
You front turn signal connect to the corresponding wires in the headlight. If you can’t find the matching wire they may have been cut or pulled back under the tank. Each black wire are grounded, chocolate and green should connect accordingly. The relay has 3 wires - black to ground, brown/white to turn signal switch yellow/green to the light checker unit. This is all based on you have the original harness. Look in the tech section under electric, lots of good info, also recommend you get a workshop manual - they all fancy the wire harness for each model too. Good luck
That’s a great diagram thank you. I’ll go through the harness tonight and see what I can find. Hoping it didn’t get up and I just have to find the end wire in the cluster of wires
 
Okay I appreciate it. I’ve found some ground wires that are open so I assumed that’s for the turn signal, just couldn’t find an open end on the chocolate or green wires for them to plug into
I too have had an issue identifying the feeds to the front flashers. It might have something to do with the wires fading over nearly 5 decades. I posted a thread a few days ago with a picture of what I think are the right connections. Good luck sorting the connections.

See my picture in my post below.
 
This is what I think are the right connections but the colours aren't 100%. That's why I think they might have faded. One of the chocolate wires on the top right of the connector looks like dark grey. I can't be sure it's correct.

1000001184.jpg
 
I too have had an issue identifying the feeds to the front flashers. It might have something to do with the wires fading over nearly 5 decades. I posted a thread a few days ago with a picture of what I think are the right connections. Good luck sorting the connections.
Okay I’ll check that out thanks. And yeah i think they’re pretty faded and dirty. I sprayed a few drops of wd40 and wiped the wires off. I can see where the cocalate and green wires come in to the headlight bucket from the signal switch, and then they go into a connecter and then go out to the rear. I’ll keep looking today and hopefully figure this all out
 
This is what I think are the right connections but the colours aren't 100%. That's why I think they might have faded. One of the chocolate wires on the top right of the connector looks like dark grey. I can't be sure it's correct.

View attachment 261230
Okay yeah I’ve seen those but I figured they were just ground points. I guess my wires are really faded too cause on my bike they just look black/grey
 
The grounds in the headlight bucket I have are most definitely very black. Can't mistake them to be honest.
Hmm well I don’t know then. I’ll take a look tonight and a get some good pictures of everything. I think i’m just overlooking something and it’s gonna be something stupid that i’m missing Lol
 
Hmm well I don’t know then. I’ll take a look tonight and a get some good pictures of everything. I think i’m just overlooking something and it’s gonna be something stupid that i’m missing Lol
Do you recognise the two connectors in my hand? Definitely chocolate and dark green. But the one on the right, the top right wire seems to be dark grey. I don't understand that wire unless it's faded to dark grey from chocolate. That's my problem. I don't want to power the bike up with that connection without understanding what it is.

The conector on the left is definitely dark green. Good luck.
 
Okay I appreciate it. I’ve found some ground wires that are open so I assumed that’s for the turn signal, just couldn’t find an open end on the chocolate or green wires for them to plug into
Ground for the front indicator is a ring that sits under the nut that holds the indicator on.

Rear turn signal earth/ground joins the loom at the rear guard under the seat
 
They can be very discolored in the head lamp bucket, but if you follow the wires out of the headlamp back to the main harness you can cut a little of the tubing back that keep all the wires together, find the right color and follow it into the headlamp.
 
The black wire coming out of the signal stalk (red circle on right) is power to the light. It'll plug into one of the 4 way connectors... green or chocolate. The black on the other side goes to the other 4 way. That make sense?


View attachment 261257
Yes seeing this after I just figured it out. The problem on mine was the 4 way connectors were all the way in the back in the middle of all the other wires.

Great picture though it’s hugely appreciated
 
Just noticed... the circle on the right. Looks like worn away insulation where it goes into the stalk? :umm:
 
Back
Top