ignition advance unit missing

japonetza

XS650 New Member
Messages
3
Reaction score
4
Points
3
Location
Indiana
Hi XS650 fans, I am new here but i ran out of search options on google. I have 1892 XS650 that i bought as a barn find. This is my first xs650 so there is some learning curve for me. I have two manuals and both say that i have to remove the ignition advance unit, the rod and so on. I want to do some engine work on the head, but when i removed the covers, my engine does not have this unit. Also the port where the wires would go is plugged. the shaft seems rusty like never was anything ever attached there. I believe it came like that from the factory, but nowhere did i find any mentioning that this unit is not needed for my engine. Can someone please tell me if they have some models that do not have this unit?

Thanks
 

Attachments

  • image_67225345.JPG
    image_67225345.JPG
    406.9 KB · Views: 38

jpdevol

Hacker of Frames,Wires and other things
Top Contributor
XS650.com Supporter
Messages
3,614
Reaction score
9,525
Points
513
Location
26187
'80-'83 US model XS's have a crank timed ignition - nothing under the cam covers
 

japonetza

XS650 New Member
Messages
3
Reaction score
4
Points
3
Location
Indiana
1980 and later have TCI electronic ignition and advance is handled by the TCI box.
Mike, thanks a lot. For a second i was really confused. I have Clymer manual and they do not mention anything about these differences... bummer... i spent two hours researching this. thank you for the shared knowledge.
 

650Skull

Cockytoo
Top Contributor
Messages
10,909
Reaction score
15,222
Points
813
Location
FNQ Australia
Clymer manual.............Supplement, Chaper 10, Late 78 and later service information...........page 196 ..........Electrical system...........ignition system 1980 and on
 
Top