my bike starts,runs,idles perfectly but will not rev!

mouser

XS650 Addict
Messages
228
Reaction score
2
Points
18
Location
Sunshine Coast British Columbia
I have an '80 with 38mm carbs from a '76. I have owned an XS since 1977. I have never had anything like this happen. The bike has been sitting for about a year. I start it regularly and have fuel stabilizer. I decided to put it back on the road. I did plugs oil battery etc. It started up, as it always has. in a couple of kicks. It idled and ran great in seconds. But absolutely refuses to rev up! It just does a blaaaaaa kind of thing and returns to running perfectly at idle. I've had the carbs off twice. The sliders, diaphram are good, all passages are clean and have been blown out. The floats are set exactly.
I began think electrical...The battery says 12.5v 14+volts running. Spark is bright. I even tried a spare tdi. Still the same! This is the first time I ever haven't been able to diagnose and fix a problem with these bikes.....????
I hope someone can steer me in the right direction...
Many thanks
 
Transfer ports plugged up? I trust you disassembled the carbs and blew the passageways clear. Cleaned all the jets and eyeballed them to make sure they were clear. Includeing the side drillings of the emulsion tube of the needle jet. By chance, are you running air filter pods on the carbs? Some seal off the air jets when fitted. Try running with pods off and see if that makes a difference. I run "Seafoam" in my gas and it really gets all the gunk out of the passageways.
 
all passageways are clear including side drillings everything has been cleaned, blown out, double checked....the gas is new, the tank is sparkling clean, the cap vents properly, the floats are perfectly set. The engine starts first kick..on choke when cold. It runs perfectly and idles with choke off within seconds....A thermal sensor shows that both plugs, and cylinder heads are functioning at the same temp. The engine will run and idle on only 1 cylinder at a time if I want. It will idle all day long at idle, even a very slow idle...but when you hit the throttle....nuthin......blaaaaaaaaaa then it will idle perfectly again. I am running K N aftermarket air breathers. same prob on or off
 
It sounds like your ignition is not advancing. On an '80, that would all be electronically controlled so I'm not sure what needs checking/fixing.
 
mouser,

If you have a TCI, try unplugging the Reg / Rect for a test to eliminate the magnetic interference from the rotor field on the TCI pickups.
 
Last edited:
my pilot jets are absolutely clean as are the small holes in the throat. The mixture screws are set at 2 turns out. Starts first kick every time. Today I'm going back to electrical. This is frustrating and confusing....
 
mouser,

If you have a TCI, try unplugging the Reg / Rect for a test to eliminate the magnetic interference from the rotor field on the TCI pickups.
 
Well!!! many hours later!!!!
I tried the Reg / Rect and found it made no difference. I tested resistance in the pickup coil. It is fine.
I cleaned and tested every electrical connection. I completely disassembled cleaned and tested my ignition switch. The primary circuit and ground on the coil test ok.
I even tried spraying fuel into the carbs when it is running.,no change in the RPM!!! just over rich fuel exhaust..white smoke..I tried manually choking both carbs when running , still no changes from a perfect idle. RPM stays at idle. It will idle easily from as low as 6-700 rpm up to I'm guessing 1200-1300rpm after that......nuthin. I tried a new set of NGK's and a new set of Champions and put the used plugs it last ran on.
I checked my compression, valve clearances, and cam chain and intake manifolds.
I am at a complete loss as to what to try next.! This one has me stumped!
44 years biking and building bikes and I have never come across this problem or any thing like it.
Anything I'm missing gentlemen???
Thanks for your input....
 
Squirrels make a nest in the air cleaner or exhaust?

Do the slides move freely up all the way and down?

Severe air leak maybe, check vacuum hose and nipples.
 
The slides work perfectly and both go up and down completely. The carbs and manifolds are 38mm from a 1976 so I don't have vacuum hoses of any sort. The sliders take 20+ seconds to completely close if I block the air passage which would indicate good diaphragms. The intake manifolds do not leak.
I'm going to remove the exhaust completely and try that...
Is it possible to put a coil from my Harley on this bike? For test purposes......without screwing something up?
 
On my bike, if I block the fly-weights so that the ignition is fixed at fully retarded, I can still rev the engine to as high as 2500 rpm. Since you cannot go above 1300 rpm, that rules out your TCI ignition not advancing, as a cause of your problem.

This points to the carbs as likely suspects.

You said the bike sat for a year. When was the last known time that you were able to rev the engine to higher rpms? Did you by any chance have the carbs off the bike 1 year ago, for cleaning or maintenance? Change any carb gaskets?

The pilot circuit needs an air supply. You can have fuel in the pilot circuit but if the air supply is blocked off, then engine would not rev up. On my carbs, the pilot jet air comes in through a hole at the carb front, goes down through a hole in the bowl gasket, along a passageway, and mixes with the pilot jet in the bowl. Hard to believe that both carbs could have the pilot air blocked???

Another set of carbs to swap in would be an interesting way to go.
 
Back
Top